Outage - Galhampton, Yeovil
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Jun 21, 2019 - 20:22 BST
Update
Update: We have engineers on route to the site.
Posted Jun 21, 2019 - 19:23 BST
Investigating
We are currently investigating an issue affecting customers at Galhampton and surrounding areas. Apologies for any inconvenience.
Posted Jun 21, 2019 - 18:42 BST
This incident affected: Broadband Services (Fixed-wireless Services).