Telephone Outage
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Mar 16, 2018 - 21:11 GMT
Identified
We are currently experiencing an outage on our telephone system.

Our suppliers' engineers are working on the problem currently and we expect to be back up and running again soon.

If you need to get hold of us then please email:

sales@wessexinternet.com or support@wessexinternet.com and one of our team will get straight back to you.

Apologies for any inconvenience.

Wessex Internet
Posted Mar 16, 2018 - 09:36 GMT